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1 Introduction 

1.1 About this Manual 
netDevice is a FDT Container for the configuration of field devices of 
different manufacturers. 

1.1.1 Overwiew 
The table below gives an overview of the descriptions provided in this 
manual: 

Chapter Section Manual 
Page 

netDevice and 
netProject 

netDevice 14 

netProject - Network 21 

Working with the 
Menus 

The Menu Bar 22 

Menu Device and Context Menu 22 

Menu Network 29 

Working with 
netDevice and 
netProject 

Getting Started - Configuration Steps 31 

The Device Catalog 35 

Installing Slave DTM or adding Device 
Description 

37 

Insert Device in Project 39 

Cutting, copying, pasting Slave Devices 40 

Delete Device from Project 41 

Working with Buslines 42 

Configuration Online/Offline Configuration 46 

Connect/disconnect Device 47 

Table 1: Overview 

1.1.2 Online Help 
netDevice contains an integrated online help facility. 

 To open the online help, select Help > Content and Index or press the
F1 key.
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1.1.3 List of Revisions 
Index Date Version Chapter Revision 
13 16-08-31 1.2000 All   Update according to the current state of the graphical user interface. 

Terminology change: ‘network view’ instead of ‘graphical network view’ 

14 17-02-24 1.2000  -   Windows 8.1 and Windwos 10  

15 18-02-16 1.2000 
2.5.1, 
5.2    

Versioning information revised (title page and this section).
Safety Message or warning added: Sections Power Disconnect while 
dowloading Firmware or Configuration, Safety Messages on Firmware or 
Configuration Download. 
Safety communication in the document revised in general. 

1.1.4 Conventions in this Manual 

Notes, operation instructions and results of operation steps are marked as 
follows: 

Notes 

Important: <important note you must follow to avoid malfunction> 

Note:  <general note> 

<note, where to find further information> 

Operation Instructions 

1. <instruction>

2. <instruction>

or 

 <instruction>

Results 

 <result> 
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1.2 Legal Notes 

Copyright 
© Hilscher Gesellschaft für Systemautomation mbH 

All rights reserved. 

The images, photographs and texts in the accompanying materials (in the 
form of a user's manual, operator's manual, Statement of Work document 
and all other document types, support texts, documentation, etc.) are 
protected by German and international copyright and by international trade 
and protective provisions. Without the prior written consent, you do not 
have permission to duplicate them either in full or in part using technical or 
mechanical methods (print, photocopy or any other method), to edit them 
using electronic systems or to transfer them. You are not permitted to make 
changes to copyright notices, markings, trademarks or ownership 
declarations. Illustrations are provided without taking the patent situation 
into account. Any company names and product designations provided in 
this document may be brands or trademarks by the corresponding owner 
and may be protected under trademark, brand or patent law. Any form of 
further use shall require the express consent from the relevant owner of the 
rights. 

Important notes 
Utmost care was/is given in the preparation of the documentation at hand 
consisting of a user's manual, operating manual and any other document 
type and accompanying texts. However, errors cannot be ruled out. 
Therefore, we cannot assume any guarantee or legal responsibility for 
erroneous information or liability of any kind. You are hereby made aware 
that descriptions found in the user's manual, the accompanying texts and 
the documentation neither represent a guarantee nor any indication on 
proper use as stipulated in the agreement or a promised attribute. It cannot 
be ruled out that the user's manual, the accompanying texts and the 
documentation do not completely match the described attributes, standards 
or any other data for the delivered product. A warranty or guarantee with 
respect to the correctness or accuracy of the information is not assumed. 

We reserve the right to modify our products and the specifications for such 
as well as the corresponding documentation in the form of a user's manual, 
operating manual and/or any other document types and accompanying 
texts at any time and without notice without being required to notify of said 
modification. Changes shall be taken into account in future manuals and do 
not represent an obligation of any kind, in particular there shall be no right 
to have delivered documents revised. The manual delivered with the 
product shall apply. 

Under no circumstances shall Hilscher Gesellschaft für Systemautomation 
mbH be liable for direct, indirect, ancillary or subsequent damage, or for 
any loss of income, which may arise after use of the information contained 
herein. 

Liability disclaimer 
The hardware and/or software was created and tested by Hilscher 
Gesellschaft für Systemautomation mbH with utmost care and is made 
available as is. No warranty can be assumed for the performance or 
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flawlessness of the hardware and/or software under all application 
conditions and scenarios and the work results achieved by the user when 
using the hardware and/or software. Liability for any damage that may have 
occurred as a result of using the hardware and/or software or the 
corresponding documents shall be limited to an event involving willful intent 
or a grossly negligent violation of a fundamental contractual obligation. 
However, the right to assert damages due to a violation of a fundamental 
contractual obligation shall be limited to contract-typical foreseeable 
damage. 

It is hereby expressly agreed upon in particular that any use or utilization of 
the hardware and/or software in connection with 

• Flight control systems in aviation and aerospace; 

• Nuclear fusion processes in nuclear power plants; 

• Medical devices used for life support and 

• Vehicle control systems used in passenger transport 

shall be excluded. Use of the hardware and/or software in any of the 
following areas is strictly prohibited: 

• For military purposes or in weaponry; 

• For designing, engineering, maintaining or operating nuclear systems; 

• In flight safety systems, aviation and flight telecommunications systems; 

• In life-support systems; 

• In systems in which any malfunction in the hardware and/or software 
may result in physical injuries or fatalities. 

You are hereby made aware that the hardware and/or software was not 
created for use in hazardous environments, which require fail-safe control 
mechanisms. Use of the hardware and/or software in this kind of 
environment shall be at your own risk; any liability for damage or loss due 
to impermissible use shall be excluded. 

Warranty 
Hilscher Gesellschaft für Systemautomation mbH hereby guarantees that 
the software shall run without errors in accordance with the requirements 
listed in the specifications and that there were no defects on the date of 
acceptance. The warranty period shall be 12 months commencing as of the 
date of acceptance or purchase (with express declaration or implied, by 
customer's conclusive behavior, e.g. putting into operation permanently). 

The warranty obligation for equipment (hardware) we produce is 36 
months, calculated as of the date of delivery ex works. The aforementioned 
provisions shall not apply if longer warranty periods are mandatory by law 
pursuant to Section 438 (1.2) BGB, Section 479 (1) BGB and Section 634a 
(1) BGB [Bürgerliches Gesetzbuch; German Civil Code] If, despite of all 
due care taken, the delivered product should have a defect, which already 
existed at the time of the transfer of risk, it shall be at our discretion to 
either repair the product or to deliver a replacement product, subject to 
timely notification of defect. 

The warranty obligation shall not apply if the notification of defect is not 
asserted promptly, if the purchaser or third party has tampered with the 
products, if the defect is the result of natural wear, was caused by 
unfavorable operating conditions or is due to violations against our 
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operating regulations or against rules of good electrical engineering 
practice, or if our request to return the defective object is not promptly 
complied with. 

Costs of support, maintenance, customization and product care 
Please be advised that any subsequent improvement shall only be free of 
charge if a defect is found. Any form of technical support, maintenance and 
customization is not a warranty service, but instead shall be charged extra. 

Additional guarantees 
Although the hardware and software was developed and tested in-depth 
with greatest care, Hilscher Gesellschaft für Systemautomation mbH shall 
not assume any guarantee for the suitability thereof for any purpose that 
was not confirmed in writing. No guarantee can be granted whereby the 
hardware and software satisfies your requirements, or the use of the 
hardware and/or software is uninterruptable or the hardware and/or 
software is fault-free. 

It cannot be guaranteed that patents and/or ownership privileges have not 
been infringed upon or violated or that the products are free from third-party 
influence. No additional guarantees or promises shall be made as to 
whether the product is market current, free from deficiency in title, or can be 
integrated or is usable for specific purposes, unless such guarantees or 
promises are required under existing law and cannot be restricted. 

Confidentiality 
The customer hereby expressly acknowledges that this document contains 
trade secrets, information protected by copyright and other patent and 
ownership privileges as well as any related rights of Hilscher Gesellschaft 
für Systemautomation mbH. The customer agrees to treat as confidential all 
of the information made available to customer by Hilscher Gesellschaft für 
Systemautomation mbH and rights, which were disclosed by Hilscher 
Gesellschaft für Systemautomation mbH and that were made accessible as 
well as the terms and conditions of this agreement itself. 

The parties hereby agree to one another that the information that each 
party receives from the other party respectively is and shall remain the 
intellectual property of said other party, unless provided for otherwise in a 
contractual agreement. 

The customer must not allow any third party to become knowledgeable of 
this expertise and shall only provide knowledge thereof to authorized users 
as appropriate and necessary. Companies associated with the customer 
shall not be deemed third parties. The customer must obligate authorized 
users to confidentiality. The customer should only use the confidential 
information in connection with the performances specified in this 
agreement. 

The customer must not use this confidential information to his own 
advantage or for his own purposes or rather to the advantage or for the 
purpose of a third party, nor must it be used for commercial purposes and 
this confidential information must only be used to the extent provided for in 
this agreement or otherwise to the extent as expressly authorized by the 
disclosing party in written form. The customer has the right, subject to the 
obligation to confidentiality, to disclose the terms and conditions of this 
agreement directly to his legal and financial consultants as would be 
required for the customer's normal business operation. 
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Export provisions 
The delivered product (including technical data) is subject to the legal 
export and/or import laws as well as any associated regulations of various 
countries, especially such laws applicable in Germany and in the United 
States. The products / hardware / software must not be exported into such 
countries for which export is prohibited under US American export control 
laws and its supplementary provisions. You hereby agree to strictly follow 
the regulations and to yourself be responsible for observing them. You are 
hereby made aware that you may be required to obtain governmental 
approval to export, reexport or import the product. 
 

 

1.3 Registered Trademarks 
Windows® XP, Windows® Vista, Windows® 7, Windows® 8, Windows® 8.1 
and Windows® 10 are registered trademarks of Microsoft Corporation. 

CANopen® is a registered trademark of CAN in AUTOMATION - 
International Users and Manufacturers Group e.V (CiA), Nürnberg. 

CC-Link is a registered trademark of Mitsubishi Electric Corporation, Tokyo, 
Japan. 

CompoNet™, DeviceNet™ and EtherNet/IP™ are trademarks of ODVA 
(Open DeviceNet Vendor Association, Inc). 

EtherCAT® is a registered trademark and a patented technology of 
Beckhoff Automation GmbH, Verl, Germany, formerly Elektro Beckhoff 
GmbH. 

Modbus is a registered trademark of Schneider Electric. 

POWERLINK is a registered trademark of B&R, Bernecker + Rainer 
Industrie-Elektronik Ges.m.b.H, Eggelsberg, Austria 

PROFIBUS® und PROFINET® are registered trademarks of PROFIBUS 
International, Karlsruhe. 

Sercos and Sercos interface are registered trademarks of Sercos 
international e. V., Suessen, Germany. 

All other mentioned trademarks are property of their respective legal 
owners. 
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2 Safety 
2.1 General Note 

The documentation in the form of a user manual, an operating instruction 
manual or other manual types, as well as the accompanying texts have 
been created for the use of the products by educated personnel. When 
using the products, all Safety Messages, Integrated Safety Messages, 
Property Damage Messages and all valid legal regulations must be obeyed. 
Technical knowledge is presumed. The user has to assure that all legal 
regulations are obeyed. 
 

2.2 Intended Use 
netDevice is a FDT Container which serves for the configuration of field 
devices of different manufacturers. 
 

2.3 Personnel Qualification 
Personnel responsible for the application of the network system shall be 
aware of the system behavior and shall be trained in using the system. 
 
 

2.4 Safety Instructions 
To ensure your own personal safety and to avoid personal injury, you 
necessarily must read, understand, and comply with the safety instructions 
and safety messages in this manual before you install and operate your 
system. 

For cases if both, personal injury as well as property damage (damage of 
equipment or device) may occur together, you find the safety instructions in 
this section. 
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2.4.1 Communication Stop during Firmware or Configuration 
Download 

If you want to perform either a firmware update (as a download) or a 
configuration download, both via the via the Master DTM or the Slave DTM 
(stand alone Slave at the root bus line), be aware of the following: 

• Together with the firmware download, an automated reset to the device 
is performed that will interrupt all network communication and all 
established connections will drop. 

• If you download the configuration during bus operation, the 
communication between master and slaves is stopped. 

Possible faulty System Operation 

• An unpredictable and unexpected behavior of machines and plant 
components may cause personal injury and property damage. 

 Stop the application program, before starting the firmware update or 
before downloading the configuration. 

 Make sure that your equipment operates under conditions that prevent 
personal injury or property damage. All network devices should be 
placed in a fail-safe mode, before starting the firmware update or before 
downloading a configuration. 

Loss of Device Parameters, Overwriting of Firmware 

• Both the firmware download and the configuration download erase the 
configuration data base. The firmware download overwrites the existing 
firmware in the network device. 

 To complete the firmware update and to make the device operable 
again, re-load the configuration after the firmware update has been 
finished. 

For devices with Ethernet technology 

 Device parameters that have been saved volatile, e. g. as the 
temporarily set IP address parameters, are getting lost during the reset. 

 In order to prevent loss of configuration data, make sure that your 
project configuration data are saved non-volatile, before you initiate a 
firmware update or download the configuration. 

 

2.4.2 Mismatching System Configuration 
Mismatching system configuration loaded into the device could result in 
faulty data mapping in the application program and thus unexpected 
equipment operation may cause personal injury or damage of equipment. 

 In the device use only a configuration suitable for the system. 
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2.5 Property Damage 
To avoid property damage and damage to your system or to your 
equipment, you necessarily must read, understand, and comply with the 
safety instructions and safety messages in this manual before you 
configure your system. 
 
 

2.5.1 Power Disconnect while dowloading Firmware or Configuration  
 

If during the process of downloading a firmware or configuration 

• the power supply to a PC with the software application is interrupted, 

• or the power supply to the Master device or the Slave device is 
interrupted, 

• or a reset to the device is done, 

this may lead to the following consequences: 

Loss of Device Parameters, Firmware Corruption 

• The firmware download or the configuration download will be interrupted 
and remains incomplete. 

• The firmware or the configuration database will be corrupted and device 
parameters will be lost. 

• Device damage may occur as the device cannot be rebooted. 

Whether these consequences occur depends on when the power 
disconnect occurs during the download. 
 

Power Drop during Write and Delete Accesses in the File System 
The FAT file system in the netX firmware is subject to certain limitations in 
its operation. Write and delete accesses in the file system (firmware 
update, configuration download etc.) can destroy the FAT (File Allocation 
Table) if the accesses cannot be completed if the power drops. Without a 
proper FAT, a firmware may not be found and cannot be started. 

Make sure that the power supply to the device is not interrupted during 
write and delete accesses in the file system (firmware update, configuration 
download, etc.). 
 
 

2.5.2 Invalid Firmware 
Loading invalid firmware files could render your device unusable.  

 Only download firmware files to the device that are valid for this device. 

Otherwise you might be forced to return your device for repair. 
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2.6 Labeling of Safety Messages 
• The Section Safety Messages at the beginning of a chapter are 

pinpointed particularly and highlighted by a signal word according to the 
degree of endangerment. The type of danger is specified by the safety 
message text  

• The Integrated Safety Messages within an instruction description are 
highlighted with a signal word according to the degree of endangerment. 
The kind of danger is specified exactly by the safety message text.  

 

Signal Word Meaning (International) Meaning (USA) 

 Indicates a direct hazard with high risk, which 
will have a consequence of death or grievous 
bodily harm if it is not avoided. 

Indicates a hazardous situation which if not 
avoided, will result in death or serious injury. 

 Indicates a possible hazard with medium risk, 
which will have a consequence of death or 
(grievous) bodily harm if it is not avoided. 

Indicates a hazardous situation which if not 
avoided, could result in death or serious injury. 

 Indicates a minor hazard with medium risk, 
which could have a consequence of minor or 
moderate bodily harm if it is not avoided. 

Indicates a hazardous situation which if not 
avoided, may result in minor or moderate injury. 

 Indicates a property damage message. Indicates a property damage message. 

Table 2: Signal Words 

 

Note: The ANSI Z535.6 standard specifies in section 4.8: "Messages 
about hazards that could result in both, physical injury and property 
damage are considered safety messages, not property damage 
messages." Thus depending of the type of danger and its consequences, 
warning messages marked by a signal word DANGER, WARNING or 
CAUTION may include both, messages on physical injury and property 
damage. 

 

In this document all Safety Instructions and Safety Messages are designed 
according both to the international used safety conventions as well as to 
the ANSI Z535.6 standard, refer to safety reference [S1]. 
 

In this document the signal words ‘WARNING’, ‘CAUTION’ and ‘NOTICE’ are used 
according to ANSI Z535.6 standard. The meaning given in ISO/IEC 26514 [S4] section 
‘11.11 Contents of warnings and cautions’ is not relevant in this manual. 

2.7 References Safety 
 

[S1] ANSI Z535.6-2011 American National Standard for Product Safety Information in 
Product Manuals, Instructions, and Other Collateral Materials 

 
 

[S4] 26514-2010  -  IEEE Standard for Adoption of ISO/IEC 26514:2008 Systems and 
Software Engineering--Requirements for Designers and Developers of User 
Documentation 
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3 netDevice and netProject 
 

3.1 netDevice 

 
Figure 1: netDevice - Network View and Device Catalog (Principle) 

The netDevice window is divided in two different areas: 

• Network View 

The left side of the netDevice window shows the current configuration as 
network view. In the network view you can arrange the single elements 
(devices and bus lines). A detailed description of the network view you find 
in section netDevice - Network View on page 15. 

• Device Catalog 
The right side of the netDevice window displays the installed devices as 
tree structure. Further information about this you find in section netDevice - 
Device Catalog on page 15. 

 
Figure 2: Example for netDevice - Network View and Device Catalog 
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3.1.1 netDevice - Network View 
The network view displays the current project as graphical network 
structure. Devices can be added by drag and drop from the device catalog 
and they are displayed as an icon in the network view. For further 
information refer to section Insert Device in Project on page 39 or to section 
Arrange Elements in the Network View on page 44. 
 

• Device Symbol and Device Description 
Above or below the device icon the name of the device with the device 
address are displayed and for master devices a continuous number, the 
network ID. The position of the text depends on the direction of the 
connection line. 
 

• Context Menu 
By a right mouse click on a device icon, the context menu is opened. The 
context menu contains all entries of the menu Device from the menu bar of 
the frame application. The context menu contains further entries for 
configuration and diagnosis. A detailed description about the Device menu 
and the context menu you find in section Menu Device and Context Menu 
on page 22. 
 

• Configuration Dialog 
For most of the DTM the configuration dialog of the appropriate device 
opens by a double click on a device icon. Otherwise the context menu is 
opened. In the configuration dialog all device and bus-specific settings can 
be made. The possibilities of the configuration are manufacturer specific. 
Closer information for device configuration can be taken from the technical 
manual of the manufacturer. 
 

 
Figure 3: netDevice and netProject - Network View (Principle) 

The network view in the netDevice window is synchronized with the 
netProject window. That means devices which you insert 

• in the network view, are also displayed automatically in the netProject 
window.  

• in the netProject window, are shown in the network view of the 
netDevice window. 



netDevice and netProject 16/52 

netDevice and netProject | FDT Container  
DOC040401OI15EN | Revision 15 | English | 2018-03 | Released | Public  © Hilscher, 2004-2018 

 
Figure 4: Example for netDevice and netProject - Network View 

 
 

3.1.1.1 Notation of the Device Description 

The device description is composed as follows: 
 

 
YYYYY [XXXX] <1> (#1) 

 

YYYYY Symbolic Name 
[XXXX] Device Description 

<1> Station Address 
(#1) Network ID 

Figure 5: Notation of the Device Description 

 

Term Description 
Symbolic Name In the Symbolic Name dialog optionally a symbolic name can be entered. This name is displayed 

in netDevice and netProject as the first part of the device description. For further information refer to 
section Change Symbolic Name on page 28. 

Device 
Description 

The Device Description indicates the name of the device and can not be edited. 
For PROFINET IO in the device catalog under ‚Stand-Alone-Slave’ or ‚Slave’ all device instances 
that derive from the same device description file, appear as separate devices. 

Station Address The Station Address is the device address on the bus and can be changed in the Master DTM 
configuration dialog. 

Network ID The Network ID is the network address of the Master and it is provided automatically when 
inserting the device. The network ID is static and cannot be changed. For Slaves no network ID 
appears. 

Table 3: Notation of the Device Description 
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3.1.2 netDevice – Topology Editor 
The Hilscher Topology Editor supports the configuration of a device 
topology (network structure), including the connections between devices 
and the related device, port and connection settings. The Topology Editor 
can be used for the configuration of different real-time-Ethernet systems. 
 

 

For information concerning the configuration of the topology refer to the 
Operating instruction manual Topology Editor. 
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3.1.3 netDevice - Device Catalog 
The device catalog displays a list of devices of all DTM installed on this PC. 
If the device catalog is loaded, it is shown as tree structure in the 
netDevice window. 

 
Figure 6: netDevice - Device Catalog (Principle) 

 

 
Figure 7: Example for netDevice - Network View and Device Catalog 

Selecting a register card, the devices are arranged by different criteria, e. g. 
by Vendor, Fieldbus or DTM Class. 

Further information about working with the device catalog you find in 
section The Device Catalog on page 35. 
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3.1.3.1 Search Function in the Device Catalog 

Using the search function in the device catalog, you can search for devices. 
You can search by device name or any combination of characters. 
 

 
Note: Do not use wildecards. 

 

 Select the Found tab. 

 
Figure 8: Search Function in the Device Catalog 

 Enter the search text in the search window, for example "COMX". 

 Press Return. 

 All devices that contain the code "COMX" in the name are displayed. 

 
Figure 9: Search Function in the Device Catalog – Search Result 
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3.1.3.2 Notations to the DTM and to the Device 

In the lower part of the device catalog window appears detailed information 
about the selected device and DTM. This includs the DTM Name, the 
Device Name as well as information about the Vendor, the Version and 
the Date. This information will help you to distinguish Master devices of 
different manufacturers that appear in the device catalog under the same 
name, based on their hardware revision or in reference to the date of 
manufacture. Under Info information such as firmware version, the feature 
set or the device description file name appears, you will need for the 
PROFINET IO ,Stand-Alone Slave' (Device) and ,Slave' (Generic Device) to 
select the device instance. 

 
Figure 10: netDevice - Device Catalog - Notations to the DTM and to the Device (Principle) 

 
Figure 11: Example for netDevice - Device Catalog 
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3.2 netProject - Network 
In the netProject the current configuration is displayed as project tree. 
Besides the device icon the name of the device and the device address are 
shown. For Master devices additionally a continuous number is displayed, 
the network ID. 

The context menu of a device is opened by a right mouse click on the 
device icon. Here via Configuration the configuration dialog of the DTM 
can be accessed. 

Via a double click on a device icon the configuration dialog of the DTM is 
opened, if supported by the DTM. In the configuration dialog then the 
parameter and general settings can be made.  

Devices which are inserted in the network view are also displayed in the 
netProject and the other way, too. 
 

             
Figure 12: netProject (Principle) (left side), Example (right side) 

The current selection in the netProject window is synchronized with the 
network view. More about multiselection you find in section on page 45. 
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4 Working with the Menus 
 

4.1 The Menu Bar 
The both menus Device and Network are displayed in the menu bar of the 
frame application, if one of the windows netProject or netDevice is 
activated. The menu Network is a dynamic menu.  

4.2 Menu Device and Context Menu 
The menu Device can be selected via the menu bar of the frame 
application.  

The context menu can be opened via right click on the device icon in the 
netDevice network view.  

Both menus contain several entries in common. Entries which are greyed 
out are disabled for the selected device. Possibly some entries are not 
supported by the device. 
 

Selecting via Description 
Menu Device The menu Device in the menu bar of the frame application includes the entries 

Connect/Disconnect, Download/Upload, Configuration, Measured Value, Simulation and 
Diagnosis* (*only Master and/or Gateway/Stand-Alone Slaves). 

Context menu 
(Right mouse click 
on the device icon) 

Additionally to the entries in the menu Device the context menu contains the entries 
Cut/Copy/Paste (enabled only for Slave devices), Additional Functions, Delete and Symbolic 
Name and for Master devices if so Start Debug Mode, Topology editor  and Network Scan … 
.  
For more refer to section Online Functions via the Context Menu on page 25. 
The context menu can contain additional manufacturer specific entries. They are not specified 
here. 

Table 4: Menu Device and Context Menu 

 
 

 

For further information to the configuration and diagnosis possibilities of a 
certain device, open the device specific help file.  

To open the help file, select Help in the DTM dialog or press the F1 key or 
refer to the manual of the installed DTM. 
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Figure 13: Menu Device (left), Example Context Menu for Master or Slave (right) 

 
Note:  The context menu can have additional or less entries as described 
here, depending by software variant. 

In the following table you find a description of the entries of the menu 
Device and the further entries of the context menu. 
 

Menu Meaning 

Connect1 Via Connect a connection from the DTM (application program) to the selected device is 
established.  
When the user connects a Master device, only this device is connected. When the user 
connects a Slave device, the Slave device is connected via the communication channel of the 
Master. Thus, the Master is also connected online. 
If a device is connected, the name of the device in the network view in netDevice is marked in 
green. For dead times during the connection is established a yellow marking appears, which is 
not always visible depending by the system speed. 
For more refer to section section Connect/disconnect Device on page 47. 

Disconnect1 Via Disconnect the connection established from the DTM (application program) to the device is 
disconnected. 
When a Master is disconnected, the Slaves of this network get also disconnected. 
The name of the device is displayed without green background, if the device is disconnected.  

Start Debug Mode1 You first must assign the device to the Master DTM, configure the Master or the Slave device 
parameters and download the configuration to the Master. 
Then via context menu > Start Debug Mode the status of the cyclical communications between 
a Master and Slave devices can be identified based on the colors of the bus lines as well as the 
debug icons. 
For more refer to section Debug Mode on page 25. 

Download1 Via Download the current configuration can be downloaded from the DTM (application 
program) into the device. For the configuration download a hardware must be assigned to the 
device in the application program.  
Adhere to the safety information applying for this command. 
For more refer to section Download to Device on page 48. 

Upload1 Via Upload the configuration stored in the device can be uploaded to the DTM (application 
program). For the configuration upload the configuration must stored in the device and the DTM 
must provide the upload function. For the configuration upload the device must be connected to 
the DTM (application program). 
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Menu Meaning 
For more refer to section Upload from Device on page 48. 

Cut/Copy/Paste1 Via Cut/Copy/Paste in the netDevice network view you can cut or copy one or multiple Slave 
devices at the Master bus line and paste them to this or to another Master bus line. The Slave 
device configuration remains maintained and further configuration is not required. 
For more refer to section Cutting, copying, pasting Slave Devices on page 40. 

Network Scan … Via Network Scan … (if included)  the current bus configuration is read back from the Slave 
devices. If for example the Master device is configured without a Slave in the netDevice network 
view at first, Slaves already available at the bus then can be inserted in the project via Network 
Scan …. 
For more refer to section Network Scan on page 26. 

Toplogy editor Via Toplogy editor (if included) the Toplogy editor is displayed.  
In addition to the device configuration in the DTM additional device and connection data (for the 
topology) can be displayed or configured in the Topology Editor. For more refer to section 
Topology Editor on page 26. 

Configuration Via Configuration the device parameters of the currently in the netDevice network view 
selected device are displayed.  
The device parameters are manufacturer specific and cannot be specified here. Also the view of 
the menu can vary depending by the DTM.2 

Measured Value Via Measured Value the measurement values of the device are shown, if supported by the 
DTM.2 

Simulation Via Simulation an offline simulation for this device is displayed if supported by the DTM.2 

Diagnosis Via Diagnosis the diagnosis dialog for this device is displayed if supported by the DTM and if 
an online diagnosis connection to the device has been established. The diagnosis functions are 
manufacturer specific.2 

Additional 
Functions 

The entries Offline Compare…, Online Compare… and Setpoint Value are not supported.  
In the submenu Service you can start or stop the communication.  
Adhere to the safety information applying for these commands.  
For more refer to section Additional Functions > Service > Start /Stop Communication on page 
27 or section Additional Functions on page 27. 

Delete Via Delete the selected device is removed from the project. 
For more refer to section Delete Device from Project on page 41. 

Symbolic Name Here an arbitrary name can be assigned to the device. This name is displayed in netDevice and 
netProject as the first part of the device description. 
For more refer to section Change Symbolic Name on page 28. 

Table 5: Entries in the Menu Device or Context Menu for the Master or Slave 

1 

 
Note: The entries Connect/Disconnect, Start Debug Mode,  Download/Upload and 
Cut/Copy/Paste are selectable for many devices. If these functions are supported by the 
selected device can only be seen after activating this menu. If they are not supported, an 
error will be reported. 

 

2 For further details refer to the manufacturer documentation. 
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4.3 Online Functions via the Context Menu 
The context menu of the device contains all entries of the Device menu in 
the menu bar. Additionally there are further entries in the context menu: 

 

4.3.1 Debug Mode 
 

 
Note:  Depending by the software variant of the DTM the debug mode is 
available or not. 

 

The debug mode allows to identify the status of the cyclical communication 
between a Master device and its Slave devices on a network based on the 
colors of the bus lines as well as the debug icons. 

For the Master device or the Master bus line this is valid: 

• Master device in operation, cyclical communication runs. (Bus line light 
green) 

 

• Master device not operable. (Bus line blue) 
 

• Master in STOP state. (Bus line red) 
 

For the Slave device or the bus line from the Master bus line to the Slave 
device this is valid: 

• Slave device in operation, cyclical communication to the Master device 
runs. (Bus line light green) 

 

• Diagnosis message available at the Master device. (Bus line yellow 
(yellow)) 

 

• Slave device not found during boot up. (Bus line blue) 
 

• Error in the Slave-to-Master communication. (Bus line red) 
 

• Slave device is not configured. (Bus line gray) 
 
 

 

For details to the debug mode refer to the Operating Instruction Manual 
of the Master DTM. 
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4.3.2 Cut/Copy/Paste 
Via the context menu entries Cut, Copy or Paste one or more Slave 
devices can be cut or copied in the netDevice network view at a Master 
bus line and then can be inserted at the same Master bus line or at another 
one. I. e. the Slave devices can be cut or copied at a Master bus line by 
selecting the Slave devices and using the Cut or Copy command from the 
context menu. Then the Slave devices can be inserted at the Master bus 
line by using the Paste command from the context menu. The configuration 
for the pasted Slave devices remains maintained. 

A detailed description for the context menu entries Cut, Copy or Paste is 
given in section Cutting, copying, pasting Slave Devices on page 40. 

 

4.3.3 Network Scan 
The menu entry Network Scan...is displayed or not depending by the 
device. 

 

With Network Scan... it is possible to find out automatically which types of 
Slave devices are attached to the Master device and how these devices are 
configured. 

To scan the network structure, proceed as follows: 
 

1. Select Network Scan... from the context menu (right mouse click). 

 A window with data of the found devices is displayed. 

2. Select the Create Devices button. 
 

 

Note: For further information to Network Scan refer to the Operating 
Instruction Manual of the respective Master DTM. 

 

4.3.4 Topology Editor  
In the topology view (graphical view of the editor with the network 
structure), the IO devices can be connected to each other. Each link is 
represented as a line that begins at a device port and ends at the port of 
another device. 

In the property views of the device, port and connection, the settings of the 
devices, ports and connections can be configured. Using this data, the 
Topology Editor checks the identity of the existing devices and whether a 
connection has been established. 

The configuration data for the network structure, the devices and 
connections specified in the Topology Editor are transmitted to the master 
DTM where they are calculated and stored togehter with the master device 
configuration. 
 

 

For information concerning the configuration of the topology refer to the 
Operating instruction manual Topology Editor. 
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4.3.5 Additional Functions 
Menu Entry Meaning 
Service In the submenu Service you can start or stop the communication. Refer to section Additional 

Functions > Service > Start /Stop Communication on page 27. 

Export In the submenu Export the current project data like project name, the fieldbus command 
structure and the device parameter are exported as CSV, DBM or XML file. 

Print The submenu Print contains the printing options of the DTM. 

Life List Information about the entries Life List, Set Station Address and License are provided in the 
Master DTM online-help. Set Station 

Address 
License 

Table 6: Additional Functions 

 

 

Depending by the software variant the context menu > Additional 
Functions can contain additional or less entries as described here. 
Further information to this is given in the help of the corresponding DTM. 

 
 
 

4.3.6 Additional Functions > Service > Start /Stop Communication 
You can manually start or stop the communication between a Master and 
Slaves. 

• Start Communication is enabled, if the communication has been 
stopped before or if the configuration requires this (Controlled release of 
communication). 

• Stop Communication is enabled, if the communication has been 
started. 

To start or to stop the communication, proceed as follows: 

Adhere to the safety information applying for this commands. 

Start Communication 
1. Connecting Device: 
 

 
Note: To start the communication of the device at the bus manually, an 
online connection from the Master DTM to the Master device is required. 
Further information can be found in section Connect/disconnect Device on 
page 47. 

 

2. Select Additional Functions > Service > Start Communication from 
the context menu (right mouse click). 

 The device communicates at the bus.  

Stop Communication 
3. Select Additional Functions > Service > Stop Communication from 

the context menu (right mouse click). 

 The communication of the device at the bus is stopped.  
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4.3.7 Delete 
With the delete function a device is removed from the project. For further 
information see section Delete Device from Project on page 41. 

 

4.3.8 Change Symbolic Name 
Generally the Device Description as described under section Notation of 
the Device Description on page 16 is used as device name. Via Symbolic 
Name an additional name for the devices can be set. 

 Right click on the device icon and select Symbolic Name. 

 The Change Symbolic Name dialog is displayed. 

 
Figure 14: Change Symbolic Name 

 Enter a symbolic name. 

 The used name then is displayed in the windows netDevice and 
netProject as name of the device. 

The Device Description is always displayed in squared brackets behind 
the symbolic name. 
 

 
YYYYY [XXXX] <1> (#1) 

 

YYYYY Symbolic Name 
[XXXX] Device Description 

<1> Station Address 
(#1) Network ID 

Figure 15: Notation of the Device Description 
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4.4 Menu Network 
The menu Network includes the network depending entries  

• Add Busline/Delete last Busline, 

• Start/Stop Project Debug Mode, 

• Device Catalog, 

• Import Device Descriptions, 

• Print Project Data. 
 

 
Note: The menu entries Add Busline and Remove last Busline are 
independent from the connected hardware; it affects only the graphical 
view of the network created in the netDevice window. It does not affect the 
real hardware configuration. 

 

 
Figure 16: Menu Network 

 

Menu Meaning 
Add Busline Adds a busline to the selected bus in the netDevice window. A Master or a Master line must be 

selected. 
Delete last Busline Deletes the last added busline. A Master or a Master line must be selected. 
Start Project Debug 
Mode / Stop Project 
Debug Mode 

Via the Start Project Debug Mode / Stop Project Debug Mode function the debug mode for 
the entire project can be started or stopped. In the Project Debug Mode the status of the 
cyclical communication between the Master and Slave devices is displayed based on the colors 
of the bus lines as well as the debug icons. 

Device Catalog Selecting the Device Catalog function, the dialog of the device catalog opens. 
The device catalog can be loaded or if necessary reloaded. For more information about the 
device catalog refer to section The Device Catalog on page 35.  

Import Device 
Descriptions … 

Via the Import Device Descriptions … dialog a device can be added using a device 
description file. For more information refer to section Installing Slave DTM or adding Device 
Description on page 37. 

Print Project Data With the function Print Project Data the current project data like project name, the fieldbus 
command structure and the device parameters are printed out. 

Table 7: Menu Network 
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4.4.1 netDevice Network Toolbar 
The network toolbar is faded in and faded out via View > Device.  

This toolbar contains the entries (from the left to the right): 

• Network > Add busline,  

• Network > Delete Last busline and  

• Network > Device Catalog  

 
Figure 17: netDevice Toolbar Network 

 

 
Note: The Network toolbar is enabled, if the focus is put on the 
netDevice or netProject window. 

 

4.4.2 netDevice Debug Toolbar 
 

 
Note: The menu entries for the debug mode are only available, if the 
debug mode is supported by the frame application.   
Also, if Start Project Debug Mode is enabled, possibly some or all 
Master DTM in the project do not support the debug mode. 

 

The debug toolbar is faded in and faded out via View > Debug.  

This toolbar contains the entries (from the left to the right): 

• Debug > Start Project Debug Mode,  

• Debug > Stop Project Debug Mode 

    
Figure 18: netDevice Debug Toolbar - Start Project Debug Mode 

 
Figure 19: netDevice Debug Toolbar - Stop Project Debug Mode 
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5 Working with netDevice and netProject 
 

5.1 Getting Started - Configuration Steps 
The following table describes the steps to configure a Master device as it is 
typical for many cases. It is presupposed that the hardware installation was 
done. 

The configuration for Master devices of different manufacturers may differ 
for some of the configuration steps of this example. 
 

# Step Short Description For detailed information see 
section 

Page 

1 Start Program - Open the configuration software  
via Start > Programs, 
- enter the user name and password in the 
dialog. 

(See Operating Instruction 
Manual of the Frame 
Application) 

- 

2 Add Slave in the Device 
Catalog 

Add the Slaves in the Device Catalog by 
importing the device description files to the 
Device Catalog. 
- Network > Import Device Descriptions. 

Installing Slave DTM or 
adding Device Description 

37 

3 Load device catalog - select Network > Device Catalog, 
- select button Reload Catalog. 
The Device Catalog is loaded automatically 
when the configuration software is opened. 

The Device Catalog 35 

4 Create new project Depending of the frame application. 
For the configuration software: 
- select File > New or File > Open. 

(See Operating Instruction 
Manual of the Frame 
Application)  

-    

5 Create Project 
Configuration 

Insert Master or Slave into configuration: 
- In the Device Catalog click to the Master, 
- and insert the device via drag and drop  
to the line in the network view, 
- in the Device Catalog click to the Slave, 
- and insert the device via drag and drop  
to the Master bus line in the network view. 

Insert Device in Project 39 

6 Scan Network Structure Alternatively scan the network structure: 
- Create the project configuration via context 
menu Additional Functions > Network 
Scan.  
- Download the configuration to the Master 
device.  
- Adhere to the safety information applying for 
this command. 

Network Scan 26 

7 Enlarge Project 
Configuration 

If necessary enlarge project configuration: 
- Therefore select Slave devices for 
enlargement. 
- Select context menu Cut and/or Copy. 
- Add Slave devices via context menu Paste. 
- Adapt Slave device address in the Master 
DTM configuration dialog. 

Multiselection, 
Cutting, copying, pasting 
Slave Devices, 
depends from device - 
(See help of the device 
manufacturer) 

40 
 
45 

8 Open the Master DTM 
configuration dialog  

Open the Master DTM configuration dialog. 
- Double click to the device icon of the Master. 
- The Master DTM configuration dialog is 
displayed. 

depends from device - 
(See help of the device 
manufacturer) 

- 

9 Select driver In the Master DTM configuration dialog: 
- select Settings > Driver, 
- select a driver.  
- if necessary, configure the driver settings. 

depends from device - 
(See help of the device 
manufacturer) 

- 

10 Assign Master device 
(with or without 
firmware) 

Assign the device to this driver. 
In the Master DTM configuration dialog: 
- select Settings > Device Assignment, 

depends from device - 
(See help of the device 
manufacturer) 

- 



Working with netDevice and netProject 32/52 

netDevice and netProject | FDT Container  
DOC040401OI15EN | Revision 15 | English | 2018-03 | Released | Public  © Hilscher, 2004-2018 

# Step Short Description For detailed information see 
section 

Page 

- select a Master device, 
- select the button Apply. 

11 Select and download 
firmware 

If not yet a firmware was loaded to the device. 
In the Master DTM configuration dialog: 
- select Settings > Firmware Download, 
- select the button Browse.., 
- select a firmware file, 
- select the button Open, 
- select the buttons Download and Yes. 
- Adhere to the safety information applying for 
this command. 

depends from device - 
(See help of the device 
manufacturer) 

- 

12 Assign Master device 
once more (with 
firmware and system 
chanal) 
For repeated download 
this step is omitted. 

In the Master DTM configuration dialog: 
- select Settings > Device Assignment, 
- select Scan, 
- select the Master device (with loaded and 
defined system channel), 
- therefore check the appropriate checkbox, 
- select Apply, 
- close the Master DTM configuration dialog 
via  
OK. 

depends from device - 
(See help of the device 
manufacturer) 

- 

13 For the Slave device 
with device assignment 
set driver settings and 
assign device 

- Double click to the device icon of the Slave. 
- The Slave DTM configuration dialog is 
displayed. 
In the Slave DTM configuration dialog: 
- select Settings 
- Set the driver and assign the device. 

depends from device - 
(See help of the device 
manufacturer) 

- 

14 Configure Slave device Configure the Slave device. 
- Double click to the device icon of the Slave. 
- The Slave DTM configuration dialog is 
displayed. 
In the Slave DTM configuration dialog: 
- configure the Slave device 
- close the Slave DTM configuration dialog via  
OK. 

depends from device - 
(See help of the device 
manufacturer) 

- 

15 Configure Master device Configure the Master device. 
- Double click to the device icon of the Master. 
- The Master DTM configuration dialog is 
displayed. 
In the Master DTM configuration dialog: 
- configure the Master device 
- close the Master DTM configuration dialog 
via OK. 

depends from device - 
(See help of the device 
manufacturer) 

- 

16 Arrange Project The project can be arranged in the network 
view by use of the mouse. 

Arrange Elements in the 
Network View 

44 

17 Configure topology  
(if this option is 
available) 

Settings in the topology editor to make: 
- Connect the devices.  
- Configure the properties for devices and 
ports. 

(See Operating Instruction 
Manual Toplogy Editor) 

- 

18 Save project - select File > Save  
or 
- select File > Save As 

(See Operating Instruction 
Manual of the Frame 
Application) 

- 

19 Connect Master device - Right click to the device icon of the Master, 
- select context menu entry Device > 
Connect. 

Connect/disconnect Device 47 

20 Download Configuration - Right click to the device icon of the Master, 
- select context menu Device > Download.  
- Adhere to the safety information applying for 
this command. 

Download to Device 48 
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# Step Short Description For detailed information see 
section 

Page 

21 Diagnosis - Right click to the device icon of the Master, 
- select context menu Diagnosis. 
- The Master DTM diagnosis dialog is 
displayed. 
- Continue with further device diagnosis, 
- close the Master DTM diagnosis dialog via  
OK. 

depends from device - 
(See help of the device 
manufacturer) 

- 

22 Disconnect  - Right click to the device icon of the Master, 
- select Device > Disconnect. 

Connect/disconnect Device 47 

Table 8: Getting Started - Configuration Steps 
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5.2 Safety Messages on Firmware or Configuration Download 

Communication Stop caused by Firmware or Configuration Download 
Initiating a firmware or configuration dowload process during bus operation 
will stop the communication and a subsequent plant stop may cause 
unpredictable and unexpected behavior of machines and plant 
components, possibly resulting in personal injury and damage to your 
equipment. 
The firmware download overwrites the existing firmware. The 
communication stop may cause loss of device parameters and possible 
device damage may occur. 
 Stop the application program, before you start the firmware or 

configuration dowload.

 Make sure that all network devices are placed in a fail-safe condition.

Mismatching System Configuration 
Mismatching system configuration loaded into the device could result in 
faulty data mapping in the application program and thus unexpected 
equipment operation may cause personal injury or damage of equipment. 
 In the device use only a configuration suitable for the system.

Power Disconnect while dowloading Firmware or Configuration 
If the power supply to the PC or device is interrupted while the firmware or 
configuration is being downloaded, the download will be aborted, the 
firmware may be corrupted, the device parameters may be lost, and the 
device may be damaged. 
 During firmware or configuration download process do not interrupt the 

power supply to the PC, or to the device and do not perform a reset to 
the device!

Invalid Firmware 
Loading invalid firmware files could render your device unusable. 
 Only proceed with a firmware version valid for your device.
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5.3 The Device Catalog 
The device catalog lists all devices, for which a DTM is installed on the 
used PC. A DTM represents one or more devices. 

Before the devices can be used in the configuration, the DTM installed on 
this PC needs to be loaded in the device catalog. This is done automatically 
during the first start of the configuration software.  

5.3.1 Load Device Catalog 
Via the menu Network > Device Catalog the device catalog is opened and 
information like name of the device and manufacturer for the individual 
DTM is displayed. 

If a new DTM is installed, the device catalog has to be reloaded, to use the 
new devices for the configuration. Further information about reloading the 
device catalog you find in section Reload Device Catalog on page 35. 

 

If the Device Catalog is loaded, the installed devices are displayed in the 
device catalog depiction of the netDevice window. 

The devices can be inserted in the project via drag and drop from the 
device catalog depiction in the netDevice window.  

A detailed description about the device catalog depiction in the netDevice 
window you find in section netDevice - Device Catalog on page 18. 

5.3.2 Reload Device Catalog 
If new DTM are installed on the PC or device descriptions are imported, the 
device catalog must be reloaded to use the new devices in the 
configuration. 

Via the menu Network > Device Catalog the device catalog opens and 
selecting the Reload button, it is searched for installed DTM on the PC. 
 

 
Note: In order to reload the device catalog the, the current user must have 
administrative rights. Otherwise the Reload button is grayed out and the 
device catalog cannot be loaded. 

 

The DTM are started and some information like device name, bus system, 
manufacturer and device type are read in when loading the device catalog. 
With this information the configuration software creates the device catalog. 

The tree structure shows the current installed devices. Now the devices can 
be inserted in the project and configured there. 
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5.3.3 Devices of other Vendors 
In order to select the desired device in the device catalog, note the details 
about the DTM and the device at the bottom of the window. When sorting 
by Fieldbus multiple devices with identical names by different vendors can 
be displayed. 

The following figure shows the device catalog sorted by Vendor.  

 
Figure 20: Device Catalog – Sorted by Vendor (Example) 

The following figure shows the device catalog sorted by Fieldbus.  

 
Figure 21: Device Catalog – Sorted by Fieldbus (Example) 

For this sorting additional DTMs of other vendors can be displayed. 
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5.4 Installing Slave DTM or adding Device Description 
In order to insert further Slave devices to the device catalog: 

1. First check, if the Slave manufacturer provides a DTM.  

2. Install this DTM. 

Alternatively or if no DTM for the Slave is available use the device 
description file of the device specified by the manufacturer.  
 

Bus System  File Type File Extension 
Real-Time Ethernet EtherCAT  DDF *.xml 
 EtherNet/IP EDS *.eds 
 PROFINET GSDML *.xml 
 Sercos  SDDML *.xml 
Fieldbus AS-Interface EDS *.eds 
 PROFIBUS DP GS, GSD, GSE, GSF *.gs, *.gsd,*.gse,*.gsf 
 CANopen EDS *.eds 
 DeviceNet EDS *.eds 

Table 9: Device Description File Types by System 

1. Select Network > Import Device Descriptions …. 

 The file selection dialog Import Device Description opens. 

 
Figure 22: netDevice – Import Device Description 

2. Select in the File of type list the bus system for which you intend to 
import device description files.  

3. Select the path for the device description file. 

4. Possibly select the path for the device icon. 

5. Reload the device catalog (see section Reload Device Catalog on page 
35). 
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5.5 PROFINET IO Device Instance 
For PROFINET IO ,Stand-Alone Slave' (Device) and ,Slave' (Generic 
Device) in the device catalog all device instances of one device description 
file appear as separate devices. To distinguish the device instances 
originating from the same device description file, the device name is 
followed by the firmware version or the range of the firmware versions the 
device instance is valid for, as shown in the following figure. 

 
Figure 23: PROFINET IO Device Instance (Example Stand-Alone Slave) 

Under Device > Info additional information is given about the selected 
device instance, such as the firmware version, the feature set or the name 
of the device description file. 
 

 
Note: If a device instance appears in the device catalog twice with the 
same range for the firmware version, you can check under Info on which 
state of the device description file the device instance is referenced. 
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5.6 Insert Device in Project 
Devices from the device catalog are added by drag and drop in the 
configuration area. With this action a DTM-Instance will be created. 
 

 

Important!  
 Only devices with the same Fieldbus or Real-time Ethernet system can 

be connected to the same network. 
 In order to select the desired device in the device catalog, note the 

details about the DTM and the device at the bottom of the window. 
When sorting by Fieldbus multiple devices with identical names by 
different vendors can be displayed. 

 

• Insert Master 
To insert a Master device in a project, the Master has to be selected in the 
depiction of the device catalog in the netDevice window. Via drag and drop 
the device is inserted in the project. 

The device can be inserted in both windows, in the network view of the 
netDevice and in the project tree of the netProject. These two windows 
are synchronized; the device is displayed in both windows. 

It is possible to have more than one network in a project and therefore 
more than one Master.  

Please note: 
In the netDevice window the Master device has to be inserted on the Root 
busline (green line). Each inserted communication channel of the Master is 
displayed at least by one fixed out-bound busline. 

In the netProject window the Master needs to be inserted on the project 
folder directly. 
 
 

• Insert Slave 
 

 
Note: A Slave or Gateway device can be connected to a bus if it supports 
the same bus system. 

 

To insert a Slave device in a project, the device has to be selected in the 
depiction of the device catalog in the netDevice window. The device is 
inserted into the project via drag and drop to the busline of the 
communication channel of the Master. 

If in the netDevice device catalog view devices are displayed repeatedly 
under the same name, this devices can be differentiated via their revision 
or the date (see section Notations to the DTM and to the Device on page 
20). 

Please note: 
In the netProject window the Slave device must be inserted on the master 
icon directly. 
 

 
Note: The Master busline or the busline between the Master busline 
and the Slave device symbol are always displayed in the same fieldbus 
or protocol specific color.  
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5.7 Cutting, copying, pasting Slave Devices 
In the netDevice network view Slave devices in a project including all of its 
configuration settings can be cut or copied and then be pasted. 

This way the project configuration can be enlarged by Slave devices the 
device configuration of which is identical or similar to that of Slave devices 
already existing in the project. 

Via the context menu > Cut, Copy and Paste Slave devices in one or more 
networks can be cut or copied and pasted at a Master bus line. To allow 
pasting, the Master must support the fieldbus protocols of all Slaves. If, for 
example DPV0-PROFIBUS Slaves and PROFIBUS DPV1 Slaves have 
been copied, they can be pasted only to a Master which supports DPV0 
and DPV1. 

By this way the configuration needs to be made only once. The newly 
added Slave devices do not need to be parameterized and configured once 
more. 
 

 

Important: Only devices of the same fieldbus or Real-time Ethernet 
system can be connected in a network. 

 
 

 
Note: If Slave devices are added in a network via the context menu Cut, 
Copy and Paste, respectively the user needs to reset the device or station 
address for these devices in the Master configuration dialog. 

 

5.7.1 Enlarging Project Configuration 
To enlarge the project configuration via Cut, Copy or Paste, proceed as 
follows: 

1. In the netDevice network view in one or more networks select the Slave 
devices to be added (see also section Multiselection on page 45). 

2. Cut or copy the Slave devices via context menu Cut or Copy. 

3. Via the context menu Paste paste these Slave devices at the Master 
bus line in the same or another network. 

4. In the Master DTM configuration dialog adapt the device or station 
address of these Slave devices, device dependent also via the Master 
DTM context menu Additional Functions. 
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5.8 Delete Device from Project 
To remove a device from the project configuration: 

 First select the device by a mouse click.  

 Then press the Del button on the keyboard. 

 Or select Delete in the context menu of the device. 

 A security question appears, if the device really shall be deleted. 

 
Figure 24: Security Question Delete Device 

 

 
Note: If a device is deleted, all settings for this device get lost. 

 

 Answer to the request by Yes. 

 The device is removed from the project configuration. 

 

If a communication channel should be deleted that has connected Slaves, 
another security question appears: 

 
Figure 25: Security Question Delete entire Network 

 

 
Note: If a device is deleted, which has additional devices assigned to; the 
entire network is also deleted. This might include Gateways with Sub 
networks. 

 Answer to the request by Yes. 

 The device is removed from the project configuration. 
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5.9 Working with Buslines 
 

5.9.1 Description of the Buslines 
Significance of the colors for the bus lines: 

• Root-bus line: The gray bus line is the root bus line. All Masters are 
connected to this line. 

• Master Busline or Branch Line of the Slave device: These bus lines 
are always in the respective specific fieldbus or protocol color. 

 

Colors of the Bus 
Line 

Meaning 

 
gray  Root Bus line 

 
yellow (dark) fieldbus specific for AS-Interface Master 

 
magenta fieldbus specific for PROFIBUS Master 

 
dark green fieldbus specific for CANopen Master 

 
orange 
yellow 

fieldbus specific for DeviceNet Master 

 
bottle green protocol specific for PROFINET IO Controller 

 
darkgold protocol specific for EtherNet/IP Scanner 

 
yellow protocol specific for EtherCAT Master 

 
red protocol specific for Sercos Master 

Table 10: Colors of the Bus Lines 
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5.9.2 Add / Remove Busline 
In the network view in the netDevice window the project can be arranged 
and edited graphically. That means, buslines can be added and removed. 
 

 
Note: The changes add / remove busline in the network view have no 
effect to the real hardware configuration. 

 
 

• Add Busline 

To add a busline: 

 Select the busline. 

 Select Network > Add Busline. 

Or 

 Select  in the toolbar. 

Or 

 Right click on the busline and select Add Busline. 

 
 A busline is added on the active bus. If more than one bus is selected, 

the busline is added only at the first selected bus. 
 

• Delete Last Busline 

To remove a busline: 

 Select a busline. 

 Select Network > Delete Last Busline. 

Or 

 Select  in the toolbar. 

Or 

 Right click on the busline and select Delete Last Busline. 

 
 The lastly added busline of this bus is removed. If more than one bus is 

selected, only the busline of the first bus is deleted. 
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5.9.3 Arrange Elements in the Network View 

 
Figure 26:  Buslines 

Buslines and device icons can be selected and moved to arrange them in 
the graphical configuration. 

To move a busline or an icon it is necessary to select it by clicking on it. A 
selected busline or device is displayed with a blue colored frame around 
the icon. 
 

• Move Device Icon 

Each device icon in the project can be moved by clicking and holding the 
left mouse button. The fixed buslines move with the icons and the built 
configuration persists. 

Another possibility to move the selected device icons consists in using the 
cursor keys. If the SHIFT key is pressed, the icons are moved faster. 
 

• Move Buslines 

Busline A is the Root Busline and it can be positioned by holding the 
mouse button.  

Busline B is the Branch Line of the Master device and can not be moved. 
If the Master Icon is moved, the busline moves with this icon automatically.  

Busline C is the basic line of the Fieldbus or the Real-time Ethernet 
system (Master bus line) inherently. It also can not be moved singly, but it 
is moved with the device icons automatically. 

Busline D and E are variable added buslines (part of the Master bus line) 
of the Fieldbus. They can be selected and moved or resized. 

Busline F is the branch line of the Slave device (bus line between the 
Master bus line and the Slave device icon). It is the connection line from the 
Slave to the bus. This line is moved automatically (like busline B) with the 
device icon. This line can not be moved independently. 
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5.9.4 Multiselection 
Multiselection makes it possible to select more than one device and/or 
busline. This is helpful if more than one element should be arranged at the 
same time. Two possibilities are available for multiselection: 

• Only with the Mouse 

 Click in the configuration window. 

 Hold the mouse button and draw a frame around the elements you want 
to select. 

 

• With Mouse and the SHIFT Key 

 Select the first element with a left mouse click (busline or device icon). 

 Hold the SHIFT key on the keyboard and click on the next elements you 
want to select. 

 

 
Note: Only buslines, which can be changed manually, can be selected. 
Descriptions of the single buslines you find in section Arrange Elements in 
the Network View on page 44. 
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6 Configuration 
 

6.1 Online/Offline Configuration 
The configuration of a device is done in the DTM configuration dialog of the 
device. 

This one can be opened via double click to the device in the netDevice 
network view, via the context menu Configuration or via Device > 
Configuration.  

A distinction is made between offline configuration and online configuration: 
 

• Offline Configuration 

If a device is parameterized offline in the application, the configuration has 
to be loaded into the device via the download to transfer the parameter 
data into the device.  

When a configuration already exists in the device, this configuration is 
overwritten by the download of the new parameter.  
 

• Online Configuration 

Requirement for the online configuration is that the hardware is installed 
and can be activated by the communication DTM. 

In case of online configuration, the parameter data set in the application is 
transferred into the device automatically without a download. If the device 
contains parameter data and supports the online Configuration, the stored 
parameter data is transferred to the application without an upload from the 
device. 
 

 
Note: It is manufacturer specific, if the used device supports an online 
Configuration. For further information about the used device please ask 
the hardware manufacturer or see the help file of the device when device 
dialog is open. 

 
 

 
Note: Upload and Download are not available for each device. If a device 
supports these functions is manufacturer specific. For further information 
about the used device please ask the hardware manufacturer or see the 
help file of the device when device dialog is open. 

 

More information about the Download you find in section Download to 
Device on page 48. More information about the Upload you find in section 
Upload from Device on page 48. 
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6.2 Connect/disconnect Device 
 

 
Note: Several DTM functions require an online connection from the DTM 
to the device, e. g. Diagnosis or the configuration download in the FDT 
Framework. 

More information about the Download you find in section Download to 
Device on page 48. More information about the Upload you find in section 
Upload from Device on page 48. 

 

A device can be connected by marking the device in the netDevice network 
view and by selecting the menu Device > Connect or via the context menu 
of the device and Connect.  
If a Master is selected and then Connect, only the Master device is 
connected. If Connect is selected in case of a marked Slave device, the 
device is connected via the parent communication channel. That means the 
Master is connected, too. 

Now the device is online. This is displayed by a green background of the 
device description. 

If the device should be disconnected from the bus, the menu Device > 
Disconnect or the context menu of the device has to be selected and 
Disconnect. In case of a Master the Slaves of this network will be 
disconnected, too. 

That means the Master is connected to the bus automatically, if a Slave is 
connected; and the Slaves are automatically disconnected, if the Master is 
disconnected. 
 

 

For more information on how to connect or disconnect a DTM to the 
device, refer to the device specific help. 
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6.2.1 Download to Device 
 

 
Note: It is manufacturer depending if the device supports the Download 
function. Look up in the manufacturer specific manual for further 
information. 

 

If a device is parameterized offline in the DTM (application program), a 
download to the device has to be made to transfer the configuration with 
the parameter data to the device.  

The download is made via the menu Device > Download or via the context 
menu of the device and then Download.  

Now the current configuration in the application program is loaded down 
into the device. 

netDevice Message: Download 
If the download is started as long as the Slave devices are connected to the 
Master device, the following message is displayed: If you attempt to 
download during bus operation, communication between master and 
Slaves is stopped. Do you really want to download? 
 

 

Important: If the communication between the Master and the Slave 
devices is stopped, the data exchange between the Master device and the 
Slave devices is stopped. 

 

 Click to Yes, if you intend to download the configuration, otherwise click 
to No.  

Adhere to the safety information applying for this command. 

6.2.2 Upload from Device 
 

 
Note: It is manufacturer depending if the device supports the Upload 
function. Look up in the manufacturer specific manual for further 
information. 

 

If a device contains parameter data and this parameter data should be 
loaded into the DTM (application program), an upload from the device has 
to be made.  

Then you have to select the menu Device > Upload to make an Upload 
from the device. The current configuration in the device is loaded into the 
application program. 
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7 Appendix 
 

7.1 User Rights 
Apart from the administrator, which has full rights of access, there are four 
further user levels, which have different rights of access in each case for 
parameterization and configuration: 
 

Action Observer Operator Maintenance Planning 
Engineer 

Menu Device and Context Menu 
   Connect Yes Yes Yes Yes 

   Disconnect Yes Yes Yes Yes 

   Upload No Yes Yes Yes 

   Download No No Yes Yes 

   Cut No No Yes Yes 

   Copy No No Yes Yes 

   Paste No No Yes Yes 

   Configuration Yes Yes Yes Yes 

   Measured Value Yes Yes Yes Yes 

   Simulation Yes Yes Yes Yes 

   Diagnosis Yes Yes Yes Yes 
Menu Network 
   Add Busline No No Yes Yes 

   Remove last Busline No No Yes Yes 

   Start Project Debug 
 Mode 

Yes Yes Yes Yes 

   Stop Project Debug 
 Mode 

Yes Yes Yes Yes 

   Device Catalog Yes Yes Yes Yes 

   Import Device 
 Descriptions … 

No No Yes Yes 

   Print Project Data Yes Yes Yes Yes 

Table 11: User Levels 

 

 

 

 



Appendix 50/52 

netDevice and netProject | FDT Container  
DOC040401OI15EN | Revision 15 | English | 2018-03 | Released | Public  © Hilscher, 2004-2018 

7.2 List of Figures 
Figure 1: netDevice - Network View and Device Catalog (Principle) 14 
Figure 2: Example for netDevice - Network View and Device Catalog 14 
Figure 3: netDevice and netProject - Network View (Principle) 15 
Figure 4: Example for netDevice and netProject - Network View 16 
Figure 5: Notation of the Device Description 16 
Figure 6: netDevice - Device Catalog (Principle) 18 
Figure 7: Example for netDevice - Network View and Device Catalog 18 
Figure 8: Search Function in the Device Catalog 19 
Figure 9: Search Function in the Device Catalog – Search Result 19 
Figure 10: netDevice - Device Catalog - Notations to the DTM and to the Device (Principle) 20 
Figure 11: Example for netDevice - Device Catalog 20 
Figure 12: netProject (Principle) (left side), Example (right side) 21 
Figure 13: Menu Device (left), Example Context Menu for Master or Slave (right) 23 
Figure 14: Change Symbolic Name 28 
Figure 15: Notation of the Device Description 28 
Figure 16: Menu Network 29 
Figure 17: netDevice Toolbar Network 30 
Figure 18: netDevice Debug Toolbar - Start Project Debug Mode 30 
Figure 19: netDevice Debug Toolbar - Stop Project Debug Mode 30 
Figure 20: Device Catalog – Sorted by Vendor (Example) 36 
Figure 21: Device Catalog – Sorted by Fieldbus (Example) 36 
Figure 22: netDevice – Import Device Description 37 
Figure 23: PROFINET IO Device Instance (Example Stand-Alone Slave) 38 
Figure 24: Security Question Delete Device 41 
Figure 25: Security Question Delete entire Network 41 
Figure 26:  Buslines 44 

 

7.3 List of Tables 
Table 1: Overview 4 
Table 2: Signal Words 13 
Table 3: Notation of the Device Description 16 
Table 4: Menu Device and Context Menu 22 
Table 5: Entries in the Menu Device or Context Menu for the Master or Slave 24 
Table 6: Additional Functions 27 
Table 7: Menu Network 29 
Table 8: Getting Started - Configuration Steps 33 
Table 9: Device Description File Types by System 37 
Table 10: Colors of the Bus Lines 42 
Table 11: User Levels 49 

 

 

 



Appendix 51/52 

netDevice and netProject | FDT Container  
DOC040401OI15EN | Revision 15 | English | 2018-03 | Released | Public  © Hilscher, 2004-2018 

7.4 Glossary 
Master 

Master devices determine the data traffic on the bus. A master may send 
messages without external request, if it is in the possession of the token 
(bus access authorization). 

Slave 

Slave devices are peripheral devices, like for example I/O devices or 
drives. Slave devices are also called passive participants. They do not 
receive the bus access authorization. That means, they may only accept 
received messages from the Master or send a message to the Master after 
enquiry of the Master. 

Device Instance 

According to the version of the PROFINET IO Slave device firmware the 
device instance specifies, which features the device has. The device 
instance is a module of the GSDML to describe the device parameters 
device specific. 

In netDevice for PROFINET IO in the device catalog under ‚Stand-Alone-
Slave’ or ‚Slave’ all device instances that derive from the same device 
description file, appear as separate devices. 

DTM 

Device Type Manager. 

The Device Type Manager (DTM) is a software module with graphical user 
interface for the configuration or for diagnosis of device. 

FDT 

Field Device Tool 

FDT specifies an interface, in order to be able to use DTM (Device Type 
Manager) in different applications of different manufacturers.  
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